re = /([\d,])\x22\d+(,)\d+\x22/m
str = '98,52,"110,18479456000019"
98809797,9880979752,"110,18479456000019"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result