use strict;
my $str = '98,52,"110,18479456000019"
98809797,9880979752,"110,18479456000019"';
my $regex = qr/([\d,])\x22\d+(,)\d+\x22/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";