const regex = /([\d,])\x22\d+(,)\d+\x22/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d,])\\x22\\d+(,)\\d+\\x22', 'gm')
const str = `98,52,"110,18479456000019"
98809797,9880979752,"110,18479456000019"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);