# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/type(?:\n\{.*?\}|[^;]*?;)\n?//gs;t' <<< "type
{
uint16 v;
uint16 m;
uint8 sw_version;
uint8 sw_m_version;
uint8 sw_p_version;
}
type double l;
type
{
uint16 n;
uint16 k;
}..."