use strict;
my $str = 'type
{
uint16 v;
uint16 m;
uint8 sw_version;
uint8 sw_m_version;
uint8 sw_p_version;
}
type double l;
type
{
uint16 n;
uint16 k;
}...';
my $regex = qr/type(?:\n\{.*?\}|[^;]*?;)\n?/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";