re = /type(?:\n\{.*?\}|[^;]*?;)\n?/
str = 'type
{
uint16 v;
uint16 m;
uint8 sw_version;
uint8 sw_m_version;
uint8 sw_p_version;
}
type double l;
type
{
uint16 n;
uint16 k;
}...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result