using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"type(?:\n\{.*?\}|[^;]*?;)\n?";
string substitution = @"";
string input = @"type
{
uint16 v;
uint16 m;
uint8 sw_version;
uint8 sw_m_version;
uint8 sw_p_version;
}
type double l;
type
{
uint16 n;
uint16 k;
}...";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}