const regex = /type(?:\n\{.*?\}|[^;]*?;)\n?/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('type(?:\\n\\{.*?\\}|[^;]*?;)\\n?', 'gs')
const str = `type
{
uint16 v;
uint16 m;
uint8 sw_version;
uint8 sw_m_version;
uint8 sw_p_version;
}
type double l;
type
{
uint16 n;
uint16 k;
}...`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);