import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "type(?:\\n\\{.*?\\}|[^;]*?;)\\n?";
final String string = "type\n"
+ "{\n"
+ "uint16 v;\n"
+ "uint16 m;\n"
+ "uint8 sw_version;\n"
+ "uint8 sw_m_version;\n"
+ "uint8 sw_p_version;\n"
+ "}\n\n"
+ "type double l;\n\n"
+ "type\n"
+ "{\n"
+ "uint16 n;\n"
+ "uint16 k;\n"
+ "}...";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}