$re = '/type(?:\n\{.*?\}|[^;]*?;)\n?/s';
$str = 'type
{
uint16 v;
uint16 m;
uint8 sw_version;
uint8 sw_m_version;
uint8 sw_p_version;
}
type double l;
type
{
uint16 n;
uint16 k;
}...';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;