package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)type(?:\n\{.*?\}|[^;]*?;)\n?`)
var str = `type
{
uint16 v;
uint16 m;
uint8 sw_version;
uint8 sw_m_version;
uint8 sw_p_version;
}
type double l;
type
{
uint16 n;
uint16 k;
}...`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}