# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"type(?:\n\{.*?\}|[^;]*?;)\n?"
test_str = ("type\n"
"{\n"
"uint16 v;\n"
"uint16 m;\n"
"uint8 sw_version;\n"
"uint8 sw_m_version;\n"
"uint8 sw_p_version;\n"
"}\n\n"
"type double l;\n\n"
"type\n"
"{\n"
"uint16 n;\n"
"uint16 k;\n"
"}...")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.