#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)type(?:\n\{.*?\}|[^;]*?;)\n?"
Local $sString = "type" & @CRLF & _
"{" & @CRLF & _
"uint16 v;" & @CRLF & _
"uint16 m;" & @CRLF & _
"uint8 sw_version;" & @CRLF & _
"uint8 sw_m_version;" & @CRLF & _
"uint8 sw_p_version;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"type double l;" & @CRLF & _
"" & @CRLF & _
"type" & @CRLF & _
"{" & @CRLF & _
"uint16 n;" & @CRLF & _
"uint16 k;" & @CRLF & _
"}..."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)