#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)([\w-]+)" & @CRLF & _
"\h*" & @CRLF & _
"(=)" & @CRLF & _
"\h*" & @CRLF & _
"(" & @CRLF & _
"(["']).*(?!["'])" & @CRLF & _
"|" & @CRLF & _
"[\w-]+" & @CRLF & _
")"
Local $sString = "th-is="atest"" & @CRLF & _
"key=value" & @CRLF & _
"" & @CRLF & _
"what = about" & @CRLF & _
"" & @CRLF & _
"one, two, three" & @CRLF & _
"" & @CRLF & _
"foo = bar and bar=foo OR foobar = "foo,= key=foo,whatever = 'oops' bar"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"foo="" & @CRLF & _
"test" & @CRLF & _
""" & @CRLF & _
"foo ? time" & @CRLF & _
"" & @CRLF & _
"IF foo = bar AND bar=foo OR foobar = "foo bar"" & @CRLF & _
"" & @CRLF & _
"what = 'if this works'" & @CRLF & _
"" & @CRLF & _
"this, is, a, test" & @CRLF & _
"" & @CRLF & _
"what="if this works"" & @CRLF & _
"" & @CRLF & _
"now=time"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")