use strict;
my $str = 'th-is="atest"
key=value
what = about
one, two, three
foo = bar and bar=foo OR foobar = "foo,= key=foo,whatever = \'oops\' bar"
foo="
test
"
foo ? time
IF foo = bar AND bar=foo OR foobar = "foo bar"
what = \'if this works\'
this, is, a, test
what="if this works"
now=time';
my $regex = qr/([\w-]+)
\h*
(=)
\h*
(
(["']).*(?!["'])
|
[\w-]+
)/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}