package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)([\w-]+)
\h*
(=)
\h*
(
(["']).*(?!["'])
|
[\w-]+
)`)
var str = `th-is="atest"
key=value
what = about
one, two, three
foo = bar and bar=foo OR foobar = "foo,= key=foo,whatever = 'oops' bar"
foo="
test
"
foo ? time
IF foo = bar AND bar=foo OR foobar = "foo bar"
what = 'if this works'
this, is, a, test
what="if this works"
now=time`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}