const regex = /([\w-]+)
\h*
(=)
\h*
(
(["']).*(?!["'])
|
[\w-]+
)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w-]+)
\\h*
(=)
\\h*
(
(["\']).*(?!["\'])
|
[\\w-]+
)', 'g')
const str = `th-is="atest"
key=value
what = about
one, two, three
foo = bar and bar=foo OR foobar = "foo,= key=foo,whatever = 'oops' bar"
foo="
test
"
foo ? time
IF foo = bar AND bar=foo OR foobar = "foo bar"
what = 'if this works'
this, is, a, test
what="if this works"
now=time`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}