$re = '/([\w-]+)
\h*
(=)
\h*
(
(["\']).*(?!["\'])
|
[\w-]+
)/x';
$str = 'th-is="atest"
key=value
what = about
one, two, three
foo = bar and bar=foo OR foobar = "foo,= key=foo,whatever = \'oops\' bar"
foo="
test
"
foo ? time
IF foo = bar AND bar=foo OR foobar = "foo bar"
what = \'if this works\'
this, is, a, test
what="if this works"
now=time';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);