import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w-]+)\n"
+ "\\h*\n"
+ "(=)\n"
+ "\\h*\n"
+ "(\n"
+ "([\"']).*(?![\"'])\n"
+ "|\n"
+ "[\\w-]+\n"
+ ")";
final String string = "th-is=\"atest\"\n"
+ "key=value\n\n"
+ "what = about\n\n"
+ "one, two, three\n\n"
+ "foo = bar and bar=foo OR foobar = \"foo,= key=foo,whatever = 'oops' bar\"\n\n\n"
+ "foo=\"\n"
+ "test\n"
+ "\"\n"
+ "foo ? time\n\n"
+ "IF foo = bar AND bar=foo OR foobar = \"foo bar\"\n\n"
+ "what = 'if this works'\n\n"
+ "this, is, a, test\n\n"
+ "what=\"if this works\"\n\n"
+ "now=time";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}