using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w-]+)
\h*
(=)
\h*
(
([""']).*(?![""'])
|
[\w-]+
)";
string input = @"th-is=""atest""
key=value
what = about
one, two, three
foo = bar and bar=foo OR foobar = ""foo,= key=foo,whatever = 'oops' bar""
foo=""
test
""
foo ? time
IF foo = bar AND bar=foo OR foobar = ""foo bar""
what = 'if this works'
this, is, a, test
what=""if this works""
now=time";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}