// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)([\w-]+)
\h*
(=)
\h*
(
(["']).*(?!["'])
|
[\w-]+
)"#).unwrap();
let string = "th-is=\"atest\"
key=value
what = about
one, two, three
foo = bar and bar=foo OR foobar = \"foo,= key=foo,whatever = 'oops' bar\"
foo=\"
test
\"
foo ? time
IF foo = bar AND bar=foo OR foobar = \"foo bar\"
what = 'if this works'
this, is, a, test
what=\"if this works\"
now=time";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}