# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
([\w-]+)
\h*
(=)
\h*
(
(["']).*(?!["'])
|
[\w-]+
)
"""
test_str = ("th-is=\"atest\"\n"
"key=value\n\n"
"what = about\n\n"
"one, two, three\n\n"
"foo = bar and bar=foo OR foobar = \"foo,= key=foo,whatever = 'oops' bar\"\n\n\n"
"foo=\"\n"
"test\n"
"\"\n"
"foo ? time\n\n"
"IF foo = bar AND bar=foo OR foobar = \"foo bar\"\n\n"
"what = 'if this works'\n\n"
"this, is, a, test\n\n"
"what=\"if this works\"\n\n"
"now=time")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.