# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+(?:[()-]\s*)?|[,()]\s*/\n/gm;t' <<< "i-phone is popular - many people like it (user-friendly system, fast, good support)"