$re = '/\s+(?:[()-]\s*)?|[,()]\s*/m';
$str = 'i-phone is popular - many people like it (user-friendly system, fast, good support)';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;