import re
regex = re.compile(r"\s+(?:[()-]\s*)?|[,()]\s*", flags=re.MULTILINE)
test_str = "i-phone is popular - many people like it (user-friendly system, fast, good support)"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)