const regex = new RegExp('\\s+(?:[()-]\\s*)?|[,()]\\s*', 'gm')
const str = `i-phone is popular - many people like it (user-friendly system, fast, good support)`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);