re = /\s+(?:[()-]\s*)?|[,()]\s*/m
str = 'i-phone is popular - many people like it (user-friendly system, fast, good support)'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result