// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+(?:[()-]\s*)?|[,()]\s*").unwrap();
let string = "i-phone is popular - many people like it (user-friendly system, fast, good support)";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}