import Foundation
let pattern = #"\s+(?:[()-]\s*)?|[,()]\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"i-phone is popular - many people like it (user-friendly system, fast, good support)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)