use strict;
my $str = 'i-phone is popular - many people like it (user-friendly system, fast, good support)';
my $regex = qr/\s+(?:[()-]\s*)?|[,()]\s*/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";