# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ ?[a-z]*oil[a-z]* ?//g;t' <<< "foil boil oil toil hello"