use strict;
my $str = 'foil boil oil toil hello';
my $regex = qr/ ?[a-z]*oil[a-z]* ?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";