import re
regex = re.compile(r" ?[a-z]*oil[a-z]* ?")
test_str = "foil boil oil toil hello"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)