import Foundation
let pattern = #" ?[a-z]*oil[a-z]* ?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"foil boil oil toil hello"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)