package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` ?[a-z]*oil[a-z]* ?`)
var str = `foil boil oil toil hello`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}