using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ?[a-z]*oil[a-z]* ?";
string substitution = @"";
string input = @"foil boil oil toil hello";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}