#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " ?[a-z]*oil[a-z]* ?"
Local $sString = "foil boil oil toil hello"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)