re = / ?[a-z]*oil[a-z]* ?/
str = 'foil boil oil toil hello'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result