const regex = / ?[a-z]*oil[a-z]* ?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' ?[a-z]*oil[a-z]* ?', 'g')
const str = `foil boil oil toil hello`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);