# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(new SystemMessage\([^)]*?)(_internalId)/$1entityId/gm;t' <<< "new SystemMessage(SystemMessageType.Error, _internalId, \"Request Failed: RequestAvailableScripts\", e)
new obj(SystemMessageType.Error, _internalId, \"Request Failed: RequestAvailableScripts\", e)"