using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(new SystemMessage\([^)]*?)(_internalId)";
string substitution = @"$1entityId";
string input = @"new SystemMessage(SystemMessageType.Error, _internalId, ""Request Failed: RequestAvailableScripts"", e)
new obj(SystemMessageType.Error, _internalId, ""Request Failed: RequestAvailableScripts"", e)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}