// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(new SystemMessage\([^)]*?)(_internalId)").unwrap();
let string = "new SystemMessage(SystemMessageType.Error, _internalId, \"Request Failed: RequestAvailableScripts\", e)
new obj(SystemMessageType.Error, _internalId, \"Request Failed: RequestAvailableScripts\", e)";
let substitution = "$1entityId";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}