use strict;
my $str = 'new SystemMessage(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)
new obj(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)';
my $regex = qr/(new SystemMessage\([^)]*?)(_internalId)/mp;
my $subst = '$1entityId';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";