$re = '/(new SystemMessage\([^)]*?)(_internalId)/m';
$str = 'new SystemMessage(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)
new obj(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)';
$subst = "$1entityId";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;