const regex = /(new SystemMessage\([^)]*?)(_internalId)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(new SystemMessage\\([^)]*?)(_internalId)', 'gm')
const str = `new SystemMessage(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)
new obj(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)`;
const subst = `$1entityId`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);