import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(new SystemMessage\\([^)]*?)(_internalId)";
final String string = "new SystemMessage(SystemMessageType.Error, _internalId, \"Request Failed: RequestAvailableScripts\", e)\n\n"
+ "new obj(SystemMessageType.Error, _internalId, \"Request Failed: RequestAvailableScripts\", e)";
final String subst = "$1entityId";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}