re = /(new SystemMessage\([^)]*?)(_internalId)/m
str = 'new SystemMessage(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)
new obj(SystemMessageType.Error, _internalId, "Request Failed: RequestAvailableScripts", e)'
subst = '$1entityId'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result