#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<ul.*?">(.*?)<\/ul>"
Local $sString = "<div id="outer">" & @CRLF & _
"<ul id="ancTop">" & @CRLF & _
"<li style="font-family: arial; font-size: 9pt;">" & @CRLF & _
"<div style="overflow: hidden; width: 690px; height: 17px;">" & @CRLF & _
" " & @CRLF & _
"<a href="#"> " & @CRLF & _
"A90 - Lorem Ipsum " & @CRLF & _
"</a> " & @CRLF & _
"</div> " & @CRLF & _
"</li> " & @CRLF & _
"<li style="font-family: arial; font-size: 9pt;"> " & @CRLF & _
"<div style="overflow: hidden; width: 690px; height: 17px;"> " & @CRLF & _
" " & @CRLF & _
"<a href="#"> " & @CRLF & _
"A85 - Lorem Ipsum " & @CRLF & _
"</a> " & @CRLF & _
"</div> " & @CRLF & _
"</li>" & @CRLF & _
"</ul>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")