import Foundation
let pattern = #"<ul.*?">(.*?)<\/ul>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
<div id="outer">
<ul id="ancTop">
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A90 - Lorem Ipsum
</a>
</div>
</li>
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A85 - Lorem Ipsum
</a>
</div>
</li>
</ul>
</div>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}