re = /<ul.*?">(.*?)<\/ul>/
str = '<div id="outer">
<ul id="ancTop">
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A90 - Lorem Ipsum
</a>
</div>
</li>
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A85 - Lorem Ipsum
</a>
</div>
</li>
</ul>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end